linux升级gcc

今天在编辑Mariadb的时候提示gcc版本过低

1、下载gcc安装包

 [root@wxjtest ~]# wget -c http://mirror.koddos.net/gcc/releases/gcc-4.8.5/gcc-4.8.5.tar.bz2 

2、解压安装包

[root@wxjtest ~]# tar xf gcc-4.8.5.tar.bz2 [root@wxjtest ~]# cd gcc-4.8.5/ 

3、预下载依赖源码包

 [root@wxjtest gcc-4.8.5]# ./contrib/download_prerequisites 

4、配置编译文件

 [root@wxjtest gcc-4.8.5]# ./configure --disable-multilib --enable-languages=c,c++

5、编译并安装

[root@wxjtest gcc-4.8.5]# make -j4 [root@wxjtest gcc-4.8.5]# make install 

6、添加环境变量并生效

[root@wxjtest gcc-4.8.5]# echo 'export PATH=/usr/gcc/bin:$PATH' >> /etc/profile [root@wxjtest gcc-4.8.5]# source /etc/profile 

7、查看 版本

[root@wxjtest gcc-4.8.5]# gcc -v 
gcc 版本 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC) 

有些版本需要用cc来调用gcc,做软连接即可

发表评论

登录... 后才能评论